接続数

COUNTER119946From 2011/5/25

HAZOP diary(安全分析日誌)

HAZOP >> 記事詳細

2017/11/14

docker eclipse

Tweet ThisSend to Facebook | by kaizen

Docker環境内でeclipseを走らせる(noVNC)

JPiere開発用Eclipse環境

apt-get update

Hit:1 http://security.ubuntu.com/ubuntu xenial-security InRelease

Hit:2 http://archive.ubuntu.com/ubuntu xenial InRelease

Hit:3 http://archive.ubuntu.com/ubuntu xenial-updates InRelease

Hit:4 http://archive.ubuntu.com/ubuntu xenial-backports InRelease

Reading package lists... Done       

$ apt-cache search java

ca-certificates-java - Common CA certificates (JKS keystore)

default-jdk - Standard Java or Java compatible Development Kit

default-jdk-doc - Standard Java or Java compatible Development Kit (documentation)

default-jdk-headless - Standard Java or Java compatible Development Kit (headless)

default-jre - Standard Java or Java compatible Runtime

default-jre-headless - Standard Java or Java compatible Runtime (headless)

doxygen - Documentation system for C, C++, Java, Python and other languages

ecj - standalone version of the Eclipse Java compiler

ecj-gcj - standalone version of the Eclipse Java compiler (native version)

gcj-5 - GCJ byte code and native compiler for Java(TM)

gcj-5-jdk - GCJ and Classpath development tools for Java(TM)

gcj-5-jre - Java runtime environment using GIJ/Classpath

gcj-5-jre-headless - Java runtime environment using GIJ/Classpath (headless version)

gcj-5-jre-lib - Java runtime library for use with gcj (jar files)

gir1.2-javascriptcoregtk-4.0 - JavaScript engine library from WebKitGTK+ - GObject introspection data

java-common - Base package for Java runtimes

javascript-common - Base support for JavaScript library packages

jayatana - Java Native Library for ayatana project

      


$ apt-get install java-common

Reading package lists... Done

Building dependency tree       

Reading state information... Done

Suggested packages:

  default-jre

The following NEW packages will be installed:

  java-common

0 upgraded, 1 newly installed, 0 to remove and 5 not upgraded.

Need to get 7742 B of archives.

After this operation, 35.8 kB of additional disk space will be used.

Get:1 http://archive.ubuntu.com/ubuntu xenial/main amd64 java-common all 0.56ubuntu2 [7742 B]

Fetched 7742 B in 0s (19.3 kB/s)

debconf: delaying package configuration, since apt-utils is not installed

Selecting previously unselected package java-common.

(Reading database ... 4768 files and directories currently installed.)

Preparing to unpack .../java-common_0.56ubuntu2_all.deb ...

Unpacking java-common (0.56ubuntu2) ...

Setting up java-common (0.56ubuntu2) ...


$ apt-get install x11

Reading package lists... Done

Building dependency tree       

Reading state information... Done

E: Unable to locate package x11


$ apt-cache search x11

culmus - TrueType and Type1 Hebrew Fonts for X11

dbus-x11 - simple interprocess messaging system (X11 deps)

(中略)

libx11-6 - X11 client-side library

libx11-6-dbg - X11 client-side library (debug package)

libx11-data - X11 client-side library

libx11-dev - X11 client-side library (development headers)

libx11-doc - X11 client-side library (development documentation)

libx11-protocol-perl - Perl module for the X Window System Protocol, version 11

libx11-xcb-dev - Xlib/XCB interface library (development headers)

libx11-xcb1 - Xlib/XCB interface library

libx11-xcb1-dbg - Xlib/XCB interface library (debug package)

(中略)

x11-apps - X applications

x11-common - X Window System (X.Org) infrastructure

x11-session-utils - X session utilities

x11-utils - X11 utilities

x11-xkb-utils - X11 XKB utilities

x11-xserver-utils - X server utilities

$ apt-get install x11-common

Reading package lists... Done

Building dependency tree       

Reading state information... Done

The following NEW packages will be installed:

  x11-common

0 upgraded, 1 newly installed, 0 to remove and 5 not upgraded.

Need to get 22.4 kB of archives.

After this operation, 316 kB of additional disk space will be used.

Get:1 http://archive.ubuntu.com/ubuntu xenial/main amd64 x11-common all 1:7.7+13ubuntu3 [22.4 kB]

Fetched 22.4 kB in 0s (27.6 kB/s)

debconf: delaying package configuration, since apt-utils is not installed

Selecting previously unselected package x11-common.

(Reading database ... 4776 files and directories currently installed.)

Preparing to unpack .../x11-common_1%3a7.7+13ubuntu3_all.deb ...

Unpacking x11-common (1:7.7+13ubuntu3) ...

Processing triggers for systemd (229-4ubuntu19) ...

Setting up x11-common (1:7.7+13ubuntu3) ...

debconf: unable to initialize frontend: Dialog

debconf: (No usable dialog-like program is installed, so the dialog based frontend cannot be used. at /usr/share/perl5/Debconf/FrontEnd/Dialog.pm line 76.)

debconf: falling back to frontend: Readline

debconf: unable to initialize frontend: Readline

debconf: (Can't locate Term/ReadLine.pm in @INC (you may need to install the Term::ReadLine module) (@INC contains: /etc/perl /usr/local/lib/x86_64-linux-gnu/perl/5.22.1 /usr/local/share/perl/5.22.1 /usr/lib/x86_64-linux-gnu/perl5/5.22 /usr/share/perl5 /usr/lib/x86_64-linux-gnu/perl/5.22 /usr/share/perl/5.22 /usr/local/lib/site_perl /usr/lib/x86_64-linux-gnu/perl-base .) at /usr/share/perl5/Debconf/FrontEnd/Readline.pm line 7.)

debconf: falling back to frontend: Teletype

update-rc.d: warning: start and stop actions are no longer supported; falling back to defaults

invoke-rc.d: could not determine current runlevel

invoke-rc.d: policy-rc.d denied execution of start.

Processing triggers for systemd (229-4ubuntu19) ...


$

$ apt-get install eclipse-rse

Reading package lists... Done

Building dependency tree       

Reading state information... Done

The following additional packages will be installed:

  ant ant-optional binfmt-support default-jdk default-jdk-headless eclipse-jdt eclipse-pde eclipse-platform eclipse-platform-data fastjar jarwrapper junit

  libapache-pom-java libasm3-java libcommons-beanutils-java libcommons-cli-java libcommons-codec-java libcommons-collections3-java libcommons-compress-java

  libcommons-dbcp-java libcommons-digester-java libcommons-httpclient-java libcommons-logging-java libcommons-net-java libcommons-parent-java libcommons-pool-java

  libdb-java libdb-je-java libdb5.3-java libdb5.3-java-jni libecj-java libice-dev libicu4j-java libjetty8-java libjline-java libjsch-java libjtidy-java liblucene2-java

  libpipeline1 libpthread-stubs0-dev libregexp-java libsm-dev libtomcat7-java libx11-dev libx11-doc libxau-dev libxcb1-dev libxdmcp-dev libxt-dev libxt6 openjdk-8-jdk

  openjdk-8-jdk-headless sat4j x11proto-core-dev x11proto-input-dev x11proto-kb-dev xorg-sgml-doctools xtrans-dev

Suggested packages:

  ant-doc ant-gcj ant-optional-gcj antlr javacc jython libbcel-java libbsf-java libgnumail-java libjaxp1.3-java libjdepend-java liblog4j1.2-java liboro-java

  libxalan2-java libxml-commons-resolver1.1-java eclipse junit-doc libcommons-beanutils-java-doc libcommons-collections3-java-doc libxz-java libcommons-dbcp-java-doc

  libgeronimo-jta-1.1-spec-java libcommons-digester-java-doc libcommons-httpclient-java-doc libavalon-framework-java libcommons-logging-java-doc libexcalibur-logkit-java

  libcommons-net-java-doc libdb5.3-java-gcj ecj libecj-java-gcj libice-doc jetty8 libjetty8-java-doc libjline-java-doc libjtidy-java-doc libsm-doc tomcat7 libxcb-doc

  libxt-doc openjdk-8-demo openjdk-8-source visualvm

The following NEW packages will be installed:

  ant ant-optional binfmt-support default-jdk default-jdk-headless eclipse-jdt eclipse-pde eclipse-platform eclipse-platform-data eclipse-rse fastjar jarwrapper junit

  libapache-pom-java libasm3-java libcommons-beanutils-java libcommons-cli-java libcommons-codec-java libcommons-collections3-java libcommons-compress-java

  libcommons-dbcp-java libcommons-digester-java libcommons-httpclient-java libcommons-logging-java libcommons-net-java libcommons-parent-java libcommons-pool-java

  libdb-java libdb-je-java libdb5.3-java libdb5.3-java-jni libecj-java libice-dev libicu4j-java libjetty8-java libjline-java libjsch-java libjtidy-java liblucene2-java

  libpipeline1 libpthread-stubs0-dev libregexp-java libsm-dev libtomcat7-java libx11-dev libx11-doc libxau-dev libxcb1-dev libxdmcp-dev libxt-dev libxt6 openjdk-8-jdk

  openjdk-8-jdk-headless sat4j x11proto-core-dev x11proto-input-dev x11proto-kb-dev xorg-sgml-doctools xtrans-dev

0 upgraded, 59 newly installed, 0 to remove and 5 not upgraded.

Need to get 164 MB of archives.

After this operation, 237 MB of additional disk space will be used.

Do you want to continue? [Y/n] Y

Get:1 http://archive.ubuntu.com/ubuntu xenial/universe amd64 ant all 1.9.6-1ubuntu1 [1892 kB]

Get:2 http://archive.ubuntu.com/ubuntu xenial/universe amd64 ant-optional all 1.9.6-1ubuntu1 [313 kB]

Get:3 http://archive.ubuntu.com/ubuntu xenial-updates/main amd64 libecj-java all 3.10.1-2ubuntu1 [1642 kB]

Get:4 http://archive.ubuntu.com/ubuntu xenial/main amd64 libcommons-pool-java all 1.6-2 [105 kB]

Get:5 http://archive.ubuntu.com/ubuntu xenial/main amd64 libcommons-collections3-java all 3.2.2-1 [599 kB]

Get:6 http://archive.ubuntu.com/ubuntu xenial/main amd64 libcommons-dbcp-java all 1.4-5ubuntu2 [148 kB]

Get:7 http://archive.ubuntu.com/ubuntu xenial-updates/universe amd64 libtomcat7-java all 7.0.68-1ubuntu0.1 [3715 kB]

Get:8 http://archive.ubuntu.com/ubuntu xenial/universe amd64 eclipse-platform-data all 3.8.1-8 [33.5 MB]

Get:9 http://archive.ubuntu.com/ubuntu xenial/universe amd64 libcommons-codec-java all 1.10-1 [232 kB]                                                                    

Get:10 http://archive.ubuntu.com/ubuntu xenial/universe amd64 libapache-pom-java all 10-2build1 [4022 B]                                                                  

Get:11 http://archive.ubuntu.com/ubuntu xenial/universe amd64 libcommons-parent-java all 39-3 [9380 B]                                                                    

Get:12 http://archive.ubuntu.com/ubuntu xenial/universe amd64 libcommons-logging-java all 1.2-1+build1 [59.5 kB]                                                          

Get:13 http://archive.ubuntu.com/ubuntu xenial/universe amd64 libcommons-httpclient-java all 3.1-12 [279 kB]                                                              

Get:14 http://archive.ubuntu.com/ubuntu xenial/universe amd64 libjetty8-java all 8.1.19-1 [1571 kB]                                                                       

Get:15 http://archive.ubuntu.com/ubuntu xenial/universe amd64 libjsch-java all 0.1.53-1ubuntu1 [267 kB]                                                                   

Get:16 http://archive.ubuntu.com/ubuntu xenial/universe amd64 liblucene2-java all 2.9.4+ds1-4 [5729 kB]                                                                   

Get:17 http://archive.ubuntu.com/ubuntu xenial/main amd64 libpipeline1 amd64 1.4.1-2 [24.6 kB]                                                                            

Get:18 http://archive.ubuntu.com/ubuntu xenial/main amd64 binfmt-support amd64 2.1.6-1 [50.7 kB]                                                                          

Get:19 http://archive.ubuntu.com/ubuntu xenial/main amd64 fastjar amd64 2:0.98-6 [66.6 kB]                                                                                

Get:20 http://archive.ubuntu.com/ubuntu xenial-updates/universe amd64 jarwrapper all 0.54ubuntu1.1 [9978 B]                                                               

Get:21 http://archive.ubuntu.com/ubuntu xenial/universe amd64 libcommons-cli-java all 1.3.1-3ubuntu1 [53.3 kB]                                                            

Get:22 http://archive.ubuntu.com/ubuntu xenial/universe amd64 sat4j all 2.3.3-1 [393 kB]                                                                                  

Get:23 http://archive.ubuntu.com/ubuntu xenial/universe amd64 eclipse-platform amd64 3.8.1-8 [109 kB]                                                                     

Get:24 http://archive.ubuntu.com/ubuntu xenial/main amd64 libdb5.3-java-jni amd64 5.3.28-11 [706 kB]                                                                      

Get:25 http://archive.ubuntu.com/ubuntu xenial/main amd64 libdb5.3-java all 5.3.28-11 [551 kB]                                                                            

Get:26 http://archive.ubuntu.com/ubuntu xenial-updates/main amd64 openjdk-8-jdk-headless amd64 8u151-b12-0ubuntu0.16.04.2 [8198 kB]                                       

Get:27 http://archive.ubuntu.com/ubuntu xenial/main amd64 default-jdk-headless amd64 2:1.8-56ubuntu2 [986 B]                                                              

Get:28 http://archive.ubuntu.com/ubuntu xenial-updates/main amd64 openjdk-8-jdk amd64 8u151-b12-0ubuntu0.16.04.2 [451 kB]                                                 

Get:29 http://archive.ubuntu.com/ubuntu xenial/main amd64 default-jdk amd64 2:1.8-56ubuntu2 [968 B]                                                                       

Get:30 http://archive.ubuntu.com/ubuntu xenial/universe amd64 junit all 3.8.2-8build1 [106 kB]                                                                            

Get:31 http://archive.ubuntu.com/ubuntu xenial/universe amd64 eclipse-jdt all 3.8.1-8 [20.7 MB]                                                                           

Get:32 http://archive.ubuntu.com/ubuntu xenial/universe amd64 libasm3-java all 3.3.2-3 [481 kB]                                                                           

Get:33 http://archive.ubuntu.com/ubuntu xenial/universe amd64 eclipse-pde amd64 3.8.1-8 [65.5 MB]                                                                         

Get:34 http://archive.ubuntu.com/ubuntu xenial/universe amd64 libcommons-net-java all 3.4-2ubuntu2 [334 kB]                                                               

Get:35 http://archive.ubuntu.com/ubuntu xenial/universe amd64 eclipse-rse all 3.4.2-2 [4702 kB]                                                                           

Get:36 http://archive.ubuntu.com/ubuntu xenial/universe amd64 libcommons-beanutils-java all 1.9.2-3 [216 kB]                                                              

Get:37 http://archive.ubuntu.com/ubuntu xenial/universe amd64 libcommons-compress-java all 1.10-2 [359 kB]                                                                

Get:38 http://archive.ubuntu.com/ubuntu xenial/universe amd64 libcommons-digester-java all 1.8.1-4 [169 kB]                                                               

Get:39 http://archive.ubuntu.com/ubuntu xenial/universe amd64 libdb-je-java all 3.3.98-1 [1424 kB]                                                                        

Get:40 http://archive.ubuntu.com/ubuntu xenial/main amd64 xorg-sgml-doctools all 1:1.11-1 [12.9 kB]                                                                       

Get:41 http://archive.ubuntu.com/ubuntu xenial-updates/main amd64 x11proto-core-dev all 7.0.31-1~ubuntu16.04.2 [254 kB]                                                   

Get:42 http://archive.ubuntu.com/ubuntu xenial/main amd64 libice-dev amd64 2:1.0.9-1 [44.9 kB]                                                                            

Get:43 http://archive.ubuntu.com/ubuntu xenial/universe amd64 libicu4j-java all 4.2.1.1-3 [5710 kB]                                                                       

Get:44 http://archive.ubuntu.com/ubuntu xenial/universe amd64 libjline-java all 1.0-2 [69.4 kB]                                                                           

Get:45 http://archive.ubuntu.com/ubuntu xenial/universe amd64 libjtidy-java all 7+svn20110807-4 [242 kB]                                                                  

Get:46 http://archive.ubuntu.com/ubuntu xenial/main amd64 libpthread-stubs0-dev amd64 0.3-4 [4068 B]                                                                      

Get:47 http://archive.ubuntu.com/ubuntu xenial/universe amd64 libregexp-java all 1.5-3build1 [35.1 kB]                                                                    

Get:48 http://archive.ubuntu.com/ubuntu xenial/main amd64 libsm-dev amd64 2:1.2.2-1 [16.2 kB]                                                                             

Get:49 http://archive.ubuntu.com/ubuntu xenial/main amd64 libxau-dev amd64 1:1.0.8-1 [11.1 kB]                                                                            

Get:50 http://archive.ubuntu.com/ubuntu xenial/main amd64 libxdmcp-dev amd64 1:1.1.2-1.1 [25.1 kB]                                                                        

Get:51 http://archive.ubuntu.com/ubuntu xenial/main amd64 x11proto-input-dev all 2.3.1-1 [118 kB]                                                                         

Get:52 http://archive.ubuntu.com/ubuntu xenial/main amd64 x11proto-kb-dev all 1.0.7-0ubuntu1 [224 kB]                                                                     

Get:53 http://archive.ubuntu.com/ubuntu xenial/main amd64 xtrans-dev all 1.3.5-1 [70.5 kB]                                                                                

Get:54 http://archive.ubuntu.com/ubuntu xenial/main amd64 libxcb1-dev amd64 1.11.1-1ubuntu1 [74.2 kB]                                                                     

Get:55 http://archive.ubuntu.com/ubuntu xenial/main amd64 libx11-dev amd64 2:1.6.3-1ubuntu2 [642 kB]                                                                      

Get:56 http://archive.ubuntu.com/ubuntu xenial/main amd64 libx11-doc all 2:1.6.3-1ubuntu2 [1465 kB]                                                                       

Get:57 http://archive.ubuntu.com/ubuntu xenial/main amd64 libxt6 amd64 1:1.1.5-0ubuntu1 [160 kB]                                                                          

Get:58 http://archive.ubuntu.com/ubuntu xenial/main amd64 libxt-dev amd64 1:1.1.5-0ubuntu1 [394 kB]                                                                       

Get:59 http://archive.ubuntu.com/ubuntu xenial/universe amd64 libdb-java all 1:5.3.21~exp1ubuntu2 [2256 B]                                                                

Fetched 164 MB in 39s (4119 kB/s)                                                                                                                                         

debconf: delaying package configuration, since apt-utils is not installed

Selecting previously unselected package ant.

(Reading database ... 9795 files and directories currently installed.)

Preparing to unpack .../ant_1.9.6-1ubuntu1_all.deb ...

Unpacking ant (1.9.6-1ubuntu1) ...

(中略)
Setting up libpipeline1:amd64 (1.4.1-2) ...

Setting up binfmt-support (2.1.6-1) ...

mount: permission denied

update-binfmts: warning: Couldn't mount the binfmt_misc filesystem on /proc/sys/fs/binfmt_misc.

mount: permission denied

update-binfmts: warning: Couldn't mount the binfmt_misc filesystem on /proc/sys/fs/binfmt_misc.

mount: permission denied

update-binfmts: warning: Couldn't mount the binfmt_misc filesystem on /proc/sys/fs/binfmt_misc.

invoke-rc.d: could not determine current runlevel

invoke-rc.d: policy-rc.d denied execution of start.

Setting up fastjar (2:0.98-6) ...

Setting up jarwrapper (0.54ubuntu1.1) ...

mount: permission denied

update-binfmts: warning: Couldn't mount the binfmt_misc filesystem on /proc/sys/fs/binfmt_misc.

Setting up libcommons-cli-java (1.3.1-3ubuntu1) ...

Setting up sat4j (2.3.3-1) ...

Setting up eclipse-platform (3.8.1-8) ...

Setting up libdb5.3-java-jni:amd64 (5.3.28-11) ...

Setting up libdb5.3-java (5.3.28-11) ...

Setting up openjdk-8-jdk-headless:amd64 (8u151-b12-0ubuntu0.16.04.2) ...

update-alternatives: using /usr/lib/jvm/java-8-openjdk-amd64/bin/idlj to provide /usr/bin/idlj (idlj) in auto mode

update-alternatives: using /usr/lib/jvm/java-8-openjdk-amd64/bin/jdeps to provide /usr/bin/jdeps (jdeps) in auto mode

update-alternatives: using /usr/lib/jvm/java-8-openjdk-amd64/bin/wsimport to provide /usr/bin/wsimport (wsimport) in auto mode

update-alternatives: using /usr/lib/jvm/java-8-openjdk-amd64/bin/rmic to provide /usr/bin/rmic (rmic) in auto mode

update-alternatives: using /usr/lib/jvm/java-8-openjdk-amd64/bin/jinfo to provide /usr/bin/jinfo (jinfo) in auto mode

update-alternatives: using /usr/lib/jvm/java-8-openjdk-amd64/bin/jsadebugd to provide /usr/bin/jsadebugd (jsadebugd) in auto mode

update-alternatives: using /usr/lib/jvm/java-8-openjdk-amd64/bin/native2ascii to provide /usr/bin/native2ascii (native2ascii) in auto mode

update-alternatives: using /usr/lib/jvm/java-8-openjdk-amd64/bin/jstat to provide /usr/bin/jstat (jstat) in auto mode

update-alternatives: using /usr/lib/jvm/java-8-openjdk-amd64/bin/javadoc to provide /usr/bin/javadoc (javadoc) in auto mode

update-alternatives: using /usr/lib/jvm/java-8-openjdk-amd64/bin/javah to provide /usr/bin/javah (javah) in auto mode

update-alternatives: using /usr/lib/jvm/java-8-openjdk-amd64/bin/jstack to provide /usr/bin/jstack (jstack) in auto mode

update-alternatives: using /usr/lib/jvm/java-8-openjdk-amd64/bin/jrunscript to provide /usr/bin/jrunscript (jrunscript) in auto mode

update-alternatives: using /usr/lib/jvm/java-8-openjdk-amd64/bin/javac to provide /usr/bin/javac (javac) in auto mode

update-alternatives: using /usr/lib/jvm/java-8-openjdk-amd64/bin/jhat to provide /usr/bin/jhat (jhat) in auto mode

update-alternatives: using /usr/lib/jvm/java-8-openjdk-amd64/bin/javap to provide /usr/bin/javap (javap) in auto mode

update-alternatives: using /usr/lib/jvm/java-8-openjdk-amd64/bin/jar to provide /usr/bin/jar (jar) in auto mode

update-alternatives: using /usr/lib/jvm/java-8-openjdk-amd64/bin/extcheck to provide /usr/bin/extcheck (extcheck) in auto mode

update-alternatives: using /usr/lib/jvm/java-8-openjdk-amd64/bin/schemagen to provide /usr/bin/schemagen (schemagen) in auto mode

update-alternatives: using /usr/lib/jvm/java-8-openjdk-amd64/bin/jps to provide /usr/bin/jps (jps) in auto mode

update-alternatives: using /usr/lib/jvm/java-8-openjdk-amd64/bin/xjc to provide /usr/bin/xjc (xjc) in auto mode

update-alternatives: using /usr/lib/jvm/java-8-openjdk-amd64/bin/jmap to provide /usr/bin/jmap (jmap) in auto mode

update-alternatives: using /usr/lib/jvm/java-8-openjdk-amd64/bin/jstatd to provide /usr/bin/jstatd (jstatd) in auto mode

update-alternatives: using /usr/lib/jvm/java-8-openjdk-amd64/bin/jdb to provide /usr/bin/jdb (jdb) in auto mode

update-alternatives: using /usr/lib/jvm/java-8-openjdk-amd64/bin/serialver to provide /usr/bin/serialver (serialver) in auto mode

update-alternatives: using /usr/lib/jvm/java-8-openjdk-amd64/bin/wsgen to provide /usr/bin/wsgen (wsgen) in auto mode

update-alternatives: using /usr/lib/jvm/java-8-openjdk-amd64/bin/jcmd to provide /usr/bin/jcmd (jcmd) in auto mode

update-alternatives: using /usr/lib/jvm/java-8-openjdk-amd64/bin/jarsigner to provide /usr/bin/jarsigner (jarsigner) in auto mode

Setting up default-jdk-headless (2:1.8-56ubuntu2) ...

Setting up openjdk-8-jdk:amd64 (8u151-b12-0ubuntu0.16.04.2) ...

update-alternatives: using /usr/lib/jvm/java-8-openjdk-amd64/bin/appletviewer to provide /usr/bin/appletviewer (appletviewer) in auto mode

update-alternatives: using /usr/lib/jvm/java-8-openjdk-amd64/bin/jconsole to provide /usr/bin/jconsole (jconsole) in auto mode

Setting up default-jdk (2:1.8-56ubuntu2) ...

Setting up junit (3.8.2-8build1) ...

Setting up eclipse-jdt (3.8.1-8) ...

Setting up libasm3-java (3.3.2-3) ...

Setting up eclipse-pde (3.8.1-8) ...

Setting up libcommons-net-java (3.4-2ubuntu2) ...

Setting up eclipse-rse (3.4.2-2) ...

Setting up libcommons-beanutils-java (1.9.2-3) ...

Setting up libcommons-compress-java (1.10-2) ...

Setting up libcommons-digester-java (1.8.1-4) ...

Setting up libdb-je-java (3.3.98-1) ...

Setting up xorg-sgml-doctools (1:1.11-1) ...

Setting up x11proto-core-dev (7.0.31-1~ubuntu16.04.2) ...

Setting up libice-dev:amd64 (2:1.0.9-1) ...

Setting up libicu4j-java (4.2.1.1-3) ...

Setting up libjline-java (1.0-2) ...

Setting up libjtidy-java (7+svn20110807-4) ...

Setting up libpthread-stubs0-dev:amd64 (0.3-4) ...

Setting up libregexp-java (1.5-3build1) ...

Setting up libsm-dev:amd64 (2:1.2.2-1) ...

Setting up libxau-dev:amd64 (1:1.0.8-1) ...

Setting up libxdmcp-dev:amd64 (1:1.1.2-1.1) ...

Setting up x11proto-input-dev (2.3.1-1) ...

Setting up x11proto-kb-dev (1.0.7-0ubuntu1) ...

Setting up xtrans-dev (1.3.5-1) ...

Setting up libxcb1-dev:amd64 (1.11.1-1ubuntu1) ...

Setting up libx11-dev:amd64 (2:1.6.3-1ubuntu2) ...

Setting up libx11-doc (2:1.6.3-1ubuntu2) ...

Setting up libxt6:amd64 (1:1.1.5-0ubuntu1) ...

Setting up libxt-dev:amd64 (1:1.1.5-0ubuntu1) ...

Setting up libdb-java (1:5.3.21~exp1ubuntu2) ...

Processing triggers for libc-bin (2.23-0ubuntu9) ...

Processing triggers for systemd (229-4ubuntu19) ...




ps
docker入門

docker run hello-world

Unable to find image 'hello-world:latest' locally

latest: Pulling from library/hello-world

9a0669468bf7: Pull complete 

Digest: sha256:0e06ef5e1945a718b02a8c319e15bae44f47039005530bc617a5d071190ed3fc

Status: Downloaded newer image for hello-world:latest


Hello from Docker!

This message shows that your installation appears to be working correctly.


To generate this message, Docker took the following steps:

 1. The Docker client contacted the Docker daemon.

 2. The Docker daemon pulled the "hello-world" image from the Docker Hub.

 3. The Docker daemon created a new container from that image which runs the

    executable that produces the output you are currently reading.

 4. The Docker daemon streamed that output to the Docker client, which sent it

    to your terminal.


To try something more ambitious, you can run an Ubuntu container with:

 $ docker run -it ubuntu bash


Share images, automate workflows, and more with a free Docker ID:

 https://cloud.docker.com/


For more examples and ideas, visit:

 https://docs.docker.com/engine/userguide/





09:57 | 投票する | 投票数(0) | コメント(0)